1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

AIDE SMS windev GSM

Discussion dans 'Windev' créé par RADOUANE999, Juin 7, 2018.

  1. RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    41
    J'aime reçus:
    13
    Bonjour
    Comment faire pour envoyer un SMS via Modem GSM avec " windev "
    le Modem GSM et connecte via Bluetooth " il a le port com7" ou par USB " le Port com3"
    j ai essai avec des code windev trouve sur le net mais ca marche pas
    merci
     
    Nawj213 et Amariaeh aiment ça.
  2. Fakirato

    Fakirato New Member
    WXG24 MEMBRE WX WXG 23 WXG 22 WXG 21

    Inscrit:
    Déc 30, 2017
    Messages:
    300
    J'aime reçus:
    770
    Bonjour
    je sait pas le type de ton modem mais généralement par utilisation des USSD

    ceci est un projet de l'utilisation de L'USSD

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
  3. RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    41
    J'aime reçus:
    13

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour
    je sait pas le type de ton modem mais généralement par utilisation des USSD

    ceci est un projet de l'utilisation de L'USSD

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Cliquez pour agrandir...
    Merci mais moi j 'utilise windev et pas windev mobile
    Mon modem est un téléphone nokia C1-c2
     
  • Fakirato

    Fakirato New Member
    WXG24 MEMBRE WX WXG 23 WXG 22 WXG 21

    Inscrit:
    Déc 30, 2017
    Messages:
    300
    J'aime reçus:
    770

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Merci mais moi j 'utilise windev et pas windev mobile
    Mon modem est un téléphone nokia C1-c2
    Cliquez pour agrandir...
    DSL j'ai mal compris le sujet

    alors c'est par les commandes AT

    Code (Windev):


    nUmero est un entier = SAI_Texte
    sMessa est une chaîne = SAI_MSG
    //ouverture du port
    ch est une chaîne
    nNbreOctet est un entier
    mes est une chaîne

    PORT est un entier = gPort_commm

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000, 5000, 5000)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 115200, 0, 8, 1, Vrai, Vrai, Faux)
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Impossible d'initialiser le port",

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("AT" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13)))

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    nNbreOctet =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, nNbreOctet)
    ch = "AT"+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13)+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13) +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (10)+ "OK" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13) +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (10)
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes) <> ch ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Communication impossible avec le terminal." + RC + "Vérifiez les branchements du modem et/ou sa configuration.")
        RETOUR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT , "AT+CMGF=1"+RC ) //"AT+CMGF=?
    BOUCLE
        SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )

    ch=

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("AT+CMGS=" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (34)+ nUmero +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (34)+RC )

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,ch )
    BOUCLE
        SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )

    n est un entier
    n =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes, ">", 1, DepuisDébut )

    c est un caractère
    c =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes ,n)

    SI c = ">" ALORS
     
        //contenu de message et validation
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (sMessa+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (26)))
        BOUCLE
            SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
        FIN
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
        mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ()

     
    C'est quoi la version de windev que tu utilise je vous upload le projet si tu veux !

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
  • suenodesign

    suenodesign Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    443
    J'aime reçus:
    650

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    C'est quoi la version de windev que tu utilise je vous upload le projet si tu veux !
    Cliquez pour agrandir...
    Merci bien

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    pour cette initiative.

    Je suis intéressé par ce projet.

    Enversion 20, il servira à tout le monde je pense.
     
    joker apprécie ceci.
  • Fakirato

    Fakirato New Member
    WXG24 MEMBRE WX WXG 23 WXG 22 WXG 21

    Inscrit:
    Déc 30, 2017
    Messages:
    300
    J'aime reçus:
    770

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Merci bien

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    pour cette initiative.

    Je suis intéressé par ce projet.

    Enversion 20, il servira à tout le monde je pense.
    Cliquez pour agrandir...
    avec plaisir juste le temps de le nettoyer :p et de l'adapter sur la 20 !
     
    joker et suenodesign aiment ça.
  • Fakirato

    Fakirato New Member
    WXG24 MEMBRE WX WXG 23 WXG 22 WXG 21

    Inscrit:
    Déc 30, 2017
    Messages:
    300
    J'aime reçus:
    770
    Il est en v18 vous pouvez l'utiliser avec la 20 !
     

    Fichiers attachés:

    • SMS SRC.rar
      Taille de fichier:
      391.4 KB
      Affichages:
      308
  • joker

    joker New Member
    MEMBRE WX

    Inscrit:
    Jan 30, 2018
    Messages:
    0
    J'aime reçus:
    6

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ,

    Je vais être [Hors sujet]
    mais notre @Administrateur est exemplaire !

    ThankS
     
    suenodesign et Fakirato aiment ça.
  • Elegi

    Elegi New Member

    Inscrit:
    Juin 22, 2018
    Messages:
    7
    J'aime reçus:
    2
    Shalom à tous et merci pour l'aide. J'aimerais savoir si une personne a ou developper l'aplication d'envoie d'sms ou il est possible d'envoyer un sms grouper a un groupe de contact a partir de son repertoir ? Moi j'ai tout fait mais au lieu d'envoie au contact selectionné, l'application envoie le message y compris tout les contact selectionner au 1er contact. Merci de m'aider !
     
  • popoy

    popoy Well-Known Member
    MEMBRE WX

    Inscrit:
    Fev 23, 2018
    Messages:
    1,390
    J'aime reçus:
    804

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Shalom à tous et merci pour l'aide. J'aimerais savoir si une personne a ou developper l'aplication d'envoie d'sms ou il est possible d'envoyer un sms grouper a un groupe de contact a partir de son repertoir ? Moi j'ai tout fait mais au lieu d'envoie au contact selectionné, l'application envoie le message y compris tout les contact selectionner au 1er contact. Merci de m'aider !
    Cliquez pour agrandir...
    y'a sûrement un problème de boucle dans ton code.
    une copie de ton projet pourrait nous donner plus d'informations pour t'aider.
     
  • Elegi

    Elegi New Member

    Inscrit:
    Juin 22, 2018
    Messages:
    7
    J'aime reçus:
    2
    Shalom a tous et merci a Popoy pour l'interet que tu portes a ma preocupatio.
    En fait, comme j'avais du mal a me trouver un script pouvant me permettre de regrouper plusieur contact dans un champs de saisie, j'ai donc essayer de creer 3 champs de saisie qui porterons chacun un numero. Voici donc mon code :

    NB: j'ai pris SAI_Text de type chaine pour que le champ de saisie concidère les contacts qui debute par un zero (ex : 07 00 00 00)
    j'ai envoyer une capture d'écran du message recu.
    Merci bien,
    Cordialement Elegi

    ***************************************************************************************

    sUmero est une chaîne = SAI_Texte
    sUmero1 est une chaîne = SAI_Texte1
    sUmero2 est une chaîne = SAI_Texte2


    sMessa est une chaîne = SAI_MSG

    //ouverture du port
    ch est une chaîne
    nNbreOctet est un entier
    mes est une chaîne

    PORT est un entier = gPort_commm
    sOuvre(PORT, 5000, 5000, 5000)
    sFixeParamètre(PORT, 115200, 0, 8, 1, Vrai, Vrai, Faux)
    SI ErreurDétectée ALORS
    Erreur("Impossible d'initialiser le port", ErreurInfo())
    FIN

    sEcrit(PORT, ChaîneVersUTF8("AT" + Caract(1:relievedface:))
    Temporisation(100)
    nNbreOctet = sDansFileEntrée(PORT)
    mes = sLit(PORT, nNbreOctet)

    ch = "AT"+ Caract(1:relievedface:+ Caract(1:relievedface: +Caract(10)+ "OK" + Caract(1:relievedface: + Caract(10)

    SI Majuscule(mes) = ch ALORS
    Erreur("Communication impossible avec le terminal." + RC + "Vérifiez les branchements du modem et/ou sa configuration.")
    RETOUR
    FIN

    sEcrit ( PORT , "AT+CMGF=1"+RC ) //"AT+CMGF=?
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )

    ch=ChaîneVersUTF8(("AT+CMGS=" + (Caract(34)+ sUmero + Caract(34)) + RC )+("AT+CMGS=" +(Caract(34)+ sUmero1 + Caract(34))+RC)+("AT+CMGS=" +(Caract(34)+ sUmero2 + Caract(34))+RC )+RC)
    //ch=ChaîneVersUTF8("AT+CMGS=" + (Caract(34)+ sUmero + sUmero1 + sUmero2 + Caract(34)) + rc )


    sEcrit(PORT,ch )
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )

    n est un entier
    n = Position (mes, ">", 1, DepuisDébut )

    c est un caractère
    c = Milieu (mes ,n)

    SI c = ">" ALORS

    //contenu de message et validation
    sEcrit(PORT, ChaîneVersUTF8(sMessa+ Caract(26)))
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )
    FIN


    sFerme(PORT)
    Ferme()
     

    Fichiers attachés:

    hasseniwalid et Amariaeh aiment ça.
  • popoy

    popoy Well-Known Member
    MEMBRE WX

    Inscrit:
    Fev 23, 2018
    Messages:
    1,390
    J'aime reçus:
    804

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Shalom a tous et merci a Popoy pour l'interet que tu portes a ma preocupatio.
    En fait, comme j'avais du mal a me trouver un script pouvant me permettre de regrouper plusieur contact dans un champs de saisie, j'ai donc essayer de creer 3 champs de saisie qui porterons chacun un numero. Voici donc mon code :

    NB: j'ai pris SAI_Text de type chaine pour que le champ de saisie concidère les contacts qui debute par un zero (ex : 07 00 00 00)
    j'ai envoyer une capture d'écran du message recu.
    Merci bien,
    Cordialement Elegi

    ***************************************************************************************

    sUmero est une chaîne = SAI_Texte
    sUmero1 est une chaîne = SAI_Texte1
    sUmero2 est une chaîne = SAI_Texte2


    sMessa est une chaîne = SAI_MSG

    //ouverture du port
    ch est une chaîne
    nNbreOctet est un entier
    mes est une chaîne

    PORT est un entier = gPort_commm
    sOuvre(PORT, 5000, 5000, 5000)
    sFixeParamètre(PORT, 115200, 0, 8, 1, Vrai, Vrai, Faux)
    SI ErreurDétectée ALORS
    Erreur("Impossible d'initialiser le port", ErreurInfo())
    FIN

    sEcrit(PORT, ChaîneVersUTF8("AT" + Caract(1:relievedface:))
    Temporisation(100)
    nNbreOctet = sDansFileEntrée(PORT)
    mes = sLit(PORT, nNbreOctet)

    ch = "AT"+ Caract(1:relievedface:+ Caract(1:relievedface: +Caract(10)+ "OK" + Caract(1:relievedface: + Caract(10)

    SI Majuscule(mes) = ch ALORS
    Erreur("Communication impossible avec le terminal." + RC + "Vérifiez les branchements du modem et/ou sa configuration.")
    RETOUR
    FIN

    sEcrit ( PORT , "AT+CMGF=1"+RC ) //"AT+CMGF=?
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )

    ch=ChaîneVersUTF8(("AT+CMGS=" + (Caract(34)+ sUmero + Caract(34)) + RC )+("AT+CMGS=" +(Caract(34)+ sUmero1 + Caract(34))+RC)+("AT+CMGS=" +(Caract(34)+ sUmero2 + Caract(34))+RC )+RC)
    //ch=ChaîneVersUTF8("AT+CMGS=" + (Caract(34)+ sUmero + sUmero1 + sUmero2 + Caract(34)) + rc )


    sEcrit(PORT,ch )
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )

    n est un entier
    n = Position (mes, ">", 1, DepuisDébut )

    c est un caractère
    c = Milieu (mes ,n)

    SI c = ">" ALORS

    //contenu de message et validation
    sEcrit(PORT, ChaîneVersUTF8(sMessa+ Caract(26)))
    BOUCLE
    SI sDansFileSortie ( PORT ) = 0 ALORS SORTIR
    FIN
    Multitâche (100)
    mes = sLit(PORT, 5000 )
    FIN


    sFerme(PORT)
    Ferme()
    Cliquez pour agrandir...
    tu essaie d'envoyer ton message a tous les numéro en même temps.
    il serait préférable d'envoyer ton message a chacun des numéro l'un après l'autre.
    Ton imprime écran affiche l'image d'un mobile?
    ne serait il pas préférable d'utiliser les fonctions SMS de WM?
     
    #12 popoy, Août 23, 2018
    Dernière édition: Août 23, 2018
  • mihoub

    mihoub New Member

    Inscrit:
    Août 26, 2018
    Messages:
    1
    J'aime reçus:
    0
    Bonjour à tous,
    Est ce qu'il y a quelqu'un qui a pu mettre une application pour envoyer le code USSD via un modem 3g ?
     
  • Elegi

    Elegi New Member

    Inscrit:
    Juin 22, 2018
    Messages:
    7
    J'aime reçus:
    2

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    tu essaie d'envoyer ton message a tous les numéro en même temps.
    il serait préférable d'envoyer ton message a chacun des numéro l'un après l'autre.
    Ton imprime écran affiche l'image d'un mobile?
    ne serait il pas préférable d'utiliser les fonctions SMS de WM?
    Cliquez pour agrandir...
    Shalom maitre Popoy,
    Merci encore une fois de plus.
    Effectivement, mon imprime écran et l'image de mon mobil qui affiche le message que j'envoie a 3 contacts a la fois.
     
  • patho

    patho New Member

    Inscrit:
    Sept 4, 2018
    Messages:
    2
    J'aime reçus:
    0
    bonjour à tous

    j'ai une application mobile qui envoies des données pas sms à un autre portable d'où je veux lire ses message et les stocker dans ma base de données.

    quelqu'un a t'il une idée.

    Merci
     
  • nougrirane

    nougrirane Active Member

    Inscrit:
    Juin 4, 2018
    Messages:
    105
    J'aime reçus:
    66
    Sur le deuxième téléphone t'as le choix :

    1- développer une application qui permet d'enregistrer les SMS après leurs lecture grâce aux fonctions SMS de windev puis les mettre sur la base données :

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    1- utiliser une application qui enregistre les SMS automatiquement sur un FTP ou sur Google Drive, DropBox ou autre au format XML puis les lire avec ton application principale et les mettre sur la base données . c'est ce que j'appels ne pas ré-inventer la roue

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Cordialement
     
  • ralaibeza

    ralaibeza New Member

    Inscrit:
    Juil 23, 2019
    Messages:
    1
    J'aime reçus:
    0

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    DSL j'ai mal compris le sujet

    alors c'est par les commandes AT

    Code (Windev):


    nUmero est un entier = SAI_Texte
    sMessa est une chaîne = SAI_MSG
    //ouverture du port
    ch est une chaîne
    nNbreOctet est un entier
    mes est une chaîne

    PORT est un entier = gPort_commm

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000, 5000, 5000)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 115200, 0, 8, 1, Vrai, Vrai, Faux)
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Impossible d'initialiser le port",

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("AT" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13)))

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    nNbreOctet =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, nNbreOctet)
    ch = "AT"+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13)+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13) +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (10)+ "OK" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (13) +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (10)
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes) <> ch ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Communication impossible avec le terminal." + RC + "Vérifiez les branchements du modem et/ou sa configuration.")
        RETOUR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT , "AT+CMGF=1"+RC ) //"AT+CMGF=?
    BOUCLE
        SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )

    ch=

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("AT+CMGS=" +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (34)+ nUmero +

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (34)+RC )

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,ch )
    BOUCLE
        SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
    mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )

    n est un entier
    n =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes, ">", 1, DepuisDébut )

    c est un caractère
    c =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (mes ,n)

    SI c = ">" ALORS
     
        //contenu de message et validation
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT,

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (sMessa+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (26)))
        BOUCLE
            SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ( PORT ) = 0 ALORS SORTIR
        FIN
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (100)
        mes =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT, 5000 )
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (PORT)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ()

     
    C'est quoi la version de windev que tu utilise je vous upload le projet si tu veux !

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Cliquez pour agrandir...
    Bonjour, pouvez-vous uploader ce projet, je suis sur windev 17. Merci
     
  • patho

    patho New Member

    Inscrit:
    Sept 4, 2018
    Messages:
    2
    J'aime reçus:
    0

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Sur le deuxième téléphone t'as le choix :

    1- développer une application qui permet d'enregistrer les SMS après leurs lecture grâce aux fonctions SMS de windev puis les mettre sur la base données :

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    1- utiliser une application qui enregistre les SMS automatiquement sur un FTP ou sur Google Drive, DropBox ou autre au format XML puis les lire avec ton application principale et les mettre sur la base données . c'est ce que j'appels ne pas ré-inventer la roue

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Cordialement
    Cliquez pour agrandir...
    Merci
     
  • KouKic

    KouKic New Member

    Inscrit:
    Mar 22, 2018
    Messages:
    11
    J'aime reçus:
    5
    Salut tlm,
    Pour ma part j'envoi une simple HTTPRequête vers l'ip du téléphone android.(ex: 192.168.1.20:8090)
    Pour cela il faut installer avant
    GSM Modem
    ici:

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    et

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    et configurer GSM Modem
    Après c'est simple:
    HTTPRequête(URLEncode(ChaîneVersUTF8("http://"+IPPort+"/SendSMS?username="+sUsername+"&password="+sPassword+"&phone="+sDestinataire+"&message="+SAI_Message)))

    Un vieux gsm dédié qu'à ça !
    Je gère le reste sous windev (table, contact..bd...)
    Bon dev
     
  • Partager cette page

    Chargement...