1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

Rétablir les Droits Windows

Discussion dans 'Windev' créé par gapplicat, Mar 9, 2018.

  1. gapplicat

    gapplicat Well-Known Member
    MEMBRE WX

    Inscrit:
    Mar 8, 2018
    Messages:
    396
    J'aime reçus:
    663
    Il arrive souvent que les droits réseau sous Windows "sautent".
    Si par exemple le client lance une réindexation (optimisation) alors que le logiciel est ouvert sur un autre poste...

    La fonction Fattribue de windev ne semble pas toujours fonctionner.

    Cette procédure utilise la fonction CALCS de Windows pour rétablir de façon rapide les droits sur les fichiers.


    Code (Text):

    Sablier(Vrai)
        HFerme("*")
       
        CheminDossier = CheminDatas
        Nfic = fOuvre(fRepExe()+"\Utilitaires\DROITS_CACLS.CMD",foCréation)
        SI Nfic <> -1 ALORS
            fEcritLigne(Nfic,"** DROITS **" + CheminDossier+"\*.*")
            ResListeFichier = fListeFichier(CheminDossier+"\*.*", frNonRécursif )
            POUR TOUTE CHAÎNE UnFichier DE ResListeFichier SEPAREE PAR RC
                fEcritLigne(Nfic,"cacls "+""""+AnsiVersOem(ExtraitChaîne(UnFichier,1))+""""+" /E /T /G ""Tout le monde"":R ")
                fEcritLigne(Nfic,"cacls "+""""+AnsiVersOem(ExtraitChaîne(UnFichier,1))+""""+" /E /T /G ""Tout le monde"":W ")
                fEcritLigne(Nfic,"cacls "+""""+AnsiVersOem(ExtraitChaîne(UnFichier,1))+""""+" /E /T /G ""Tout le monde"":C ")
                fEcritLigne(Nfic,"cacls "+""""+AnsiVersOem(ExtraitChaîne(UnFichier,1))+""""+" /E /T /G ""Tout le monde"":F ")
            FIN
            fFerme(Nfic)
        FIN      
       
        Multitâche(100)
       
        nPID = LanceAppli(fRepExe()+"\Utilitaires\DROITS_CACLS.CMD", exeBloquant)
        SI ErreurDétectée ALORS  
            Erreur()
        SINON
            info("Les droits sur les fichiers ont été appliqués.")
        FIN
       
     
     
    charlie, suenodesign et joker aiment ça.
  2. ProDev

    ProDev Well-Known Member
    MEMBRE WX

    Inscrit:
    Fev 11, 2018
    Messages:
    345
    J'aime reçus:
    354
    Merci

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
  3. michel

    michel Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    161
    J'aime reçus:
    562
    merci pour le partage
     
  4. warjoen

    warjoen Active Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    147
    J'aime reçus:
    111
    Thanks....
     
  5. charlie

    charlie Active Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    166
    J'aime reçus:
    178
    Merci pour le code.
     
  6. Kill3rbko

    Kill3rbko Member

    Inscrit:
    Mar 8, 2018
    Messages:
    36
    J'aime reçus:
    11
    Trop top!
    Et moi qui me farcissait manuellement un par un :D
    Merci!
     

Partager cette page

Chargement...