1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

AIDE [RESOLU] Contrôle des images avant de poster

Discussion dans 'Windev Mobile' créé par Man, Fev 6, 2019.

  1. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28
    Je ne parviens pas à récupérer les valeurs SVP besoin d'aide
     
  2. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    , Bonsoir j'ai évolué avec le code mais je suis buté car je ne parviens pas à charger le média. Je colle ici le code source et le résultat en Capture d'écran.
    Code (Windev):
    CheminImage est une chaîne
    CheminImage =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (albumImage)
    SI CheminImage = "" ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
        RETOUR
    FIN

    IMG_Image = CheminImage
    oRequête est un restRequête
    oRequête.Méthode=httpPost
    oRequête..URL="[URL]https://api.sightengine.com/1.0/nudity.json[/URL]"

    //oRequête.ContentType=typeMimeJPEG
    Image est une Image = CheminImage
    oRequête.Contenu=

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (Image)
    oRequête..Entête["api_user"] = API_User
    oRequête..Entête["api_secret"] = MDP
    oRequête..Entête["media"] = Image

    //oRequête..Entête["models"]="{nudity}"
    response est une restRéponse= RESTEnvoie(oRequête)
    //cc est un buffer = response
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (errComplet))
    SINON
        vMonProduit est un Variant =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (response.Contenu)
        sProduit est une chaîne  =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (vMonProduit)
        LIB_Statut=

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Pas de nudité : %1"+[" "]+"Opérations : %5"+RC+"Nudité partielle : %2"+[" "]+"Média_Uri : %7"+RC+...
        "Nudité brute : %3"+[" "]+"Media_ID : %8"+RC+"Statut : %4"+[" "]+" Req_ID : %6",...
        vMonProduit.nudity.safe,vMonProduit.nudity.Partial,vMonProduit.nudity.raw,...
        vMonProduit.status,vMonProduit.operations,vMonProduit.request.id,vMonProduit.media.uri,vMonProduit.media.id)
    FIN
    ///////////////////////////////////////////////////////////////////////////////////////////////////////
    J'ai des maux de tête à cause de ce code.
    Si vous pouvez me débloquer car je ne compte que sur votre expérience.
    Merci d'avance
     

    Fichiers attachés:

    #22 Man, Fev 14, 2019, à 4:57 PM
    Dernière édition par un modérateur: Fev 14, 2019, à 7:16 PM
  3. FreudWD

    FreudWD Well-Known Member
    MEMBRE WX WXG 21

    Inscrit:
    Jan 22, 2018
    Messages:
    145
    J'aime reçus:
    280
    Salut Man,

    Ma seule idée, c’est que l’image doit être dans la variable média du post.
    Je tenterais bien un déplacement du chargement de l’image et de garder un contenu pour avoir le post :
    Code (Text):
    oRequête.Contenu = "Rien"
    ...
    oRequête..Entête["media"] = dChargeImage(Image)
    A+.
     
  4. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Salut Man,

    Ma seule idée, c’est que l’image doit être dans la variable média du post.
    Je tenterais bien un déplacement du chargement de l’image et de garder un contenu pour avoir le post :
    Code (Text):
    oRequête.Contenu = "Rien"
    ...
    oRequête..Entête["media"] = dChargeImage(Image)
    A+.
    Cliquez pour agrandir...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonsoir j'ai été ravi de ta réaction mais appliquant ta proposition toujours rien...
    Comme le montre la capture d''écran
     

    Fichiers attachés:

  • FreudWD

    FreudWD Well-Known Member
    MEMBRE WX WXG 21

    Inscrit:
    Jan 22, 2018
    Messages:
    145
    J'aime reçus:
    280
    Il nous faudrait un peu plus d’information sur l’erreur,
    pour savoir si cela vient du post ou du compte,
    tests-moi ce code dans la partie SINON :
    Code (Text):
        vMonProduit est un Variant = JSONVersVariant(response.Contenu)
        SI vMonProduit.status = "failure" ALORS
            LIB_Statut = ChaîneConstruit("Erreur : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
                vMonProduit.error.code,vMonProduit.error.type,vMonProduit.error.message)
        SINON
            LIB_Statut = ChaîneConstruit("Pas de nudité : %1"+[" "]+"Opérations : %5"+RC+"Nudité partielle : %2"+[" "]+"Média_Uri : %7"+RC+...
                "Nudité brute : %3"+[" "]+"Media_ID : %8"+RC+"Statut : %4"+[" "]+" Req_ID : %6",...
                vMonProduit.nudity.safe,vMonProduit.nudity.Partial,vMonProduit.nudity.raw,...
                vMonProduit.status,vMonProduit.operations,vMonProduit.request.id,vMonProduit.media.uri,vMonProduit.media.id)
        FIN
    A+.
     
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Il nous faudrait un peu plus d’information sur l’erreur,
    pour savoir si cela vient du post ou du compte,
    tests-moi ce code dans la partie SINON :
    Code (Text):
        vMonProduit est un Variant = JSONVersVariant(response.Contenu)
        SI vMonProduit.status = "failure" ALORS
            LIB_Statut = ChaîneConstruit("Erreur : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
                vMonProduit.error.code,vMonProduit.error.type,vMonProduit.error.message)
        SINON
            LIB_Statut = ChaîneConstruit("Pas de nudité : %1"+[" "]+"Opérations : %5"+RC+"Nudité partielle : %2"+[" "]+"Média_Uri : %7"+RC+...
                "Nudité brute : %3"+[" "]+"Media_ID : %8"+RC+"Statut : %4"+[" "]+" Req_ID : %6",...
                vMonProduit.nudity.safe,vMonProduit.nudity.Partial,vMonProduit.nudity.raw,...
                vMonProduit.status,vMonProduit.operations,vMonProduit.request.id,vMonProduit.media.uri,vMonProduit.media.id)
        FIN
    A+.
    Cliquez pour agrandir...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonne après-midi je viens de tester ce fragment de code que tu viens de me donner voici les résultats
    Erreur : 4 Type : argument_error
    Message : No media specified
     

    Fichiers attachés:

  • FreudWD

    FreudWD Well-Known Member
    MEMBRE WX WXG 21

    Inscrit:
    Jan 22, 2018
    Messages:
    145
    J'aime reçus:
    280
    Salut Man,

    Pour pouvoir donner un nom de variable au fichier, il n’y a que le formulaire :
    Code (Windev):
    CheminImage est une chaîne
    CheminImage =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (albumImage)
    SI CheminImage = "" ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
        RETOUR
    FIN

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG")

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "api_user", API_User)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "api_secret", MDP)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "media", CheminImage, "application/octet-stream") // Aussi image/jpeg ou image/png
    SI PAS

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "https://api.sightengine.com/1.0/nudity.json", httpPost, "", "", typeMimeFormulaireMultiPartie) ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Echec de l'envoi du formulaire : ",

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
    SINON
        vMonProduit est un Variant =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
        SI vMonProduit.status = "failure" ALORS
            LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Erreur : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
                vMonProduit.error.code,vMonProduit.error.type,vMonProduit.error.message)
        SINON
            LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Pas de nudité : %1"+[" "]+"Opérations : %5"+RC+"Nudité partielle : %2"+[" "]+"Média_Uri : %7"+RC+...
                "Nudité brute : %3"+[" "]+"Media_ID : %8"+RC+"Statut : %4"+[" "]+" Req_ID : %6",...
                vMonProduit.nudity.safe,vMonProduit.nudity.Partial,vMonProduit.nudity.raw,...
                vMonProduit.status,vMonProduit.operations,vMonProduit.request.id,vMonProduit.media.uri,vMonProduit.media.id)
        FIN
    FIN
    A+.
     
    #27 FreudWD, Fev 17, 2019, à 5:49 PM
    Dernière édition par un modérateur: Fev 19, 2019, à 4:31 PM
    Man et suenodesign aiment ça.
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Salut Man,

    Pour pouvoir donner un nom de variable au fichier, il n’y a que le formulaire :
    Code (Text):
    CheminImage est une chaîne
    CheminImage = AlbumSélecteur(albumImage)
    SI CheminImage = "" ALORS
        Erreur(ErreurInfo())
        RETOUR
    FIN

    HTTPCréeFormulaire("CHKIMG")
    HTTPAjouteParamètre("CHKIMG", "api_user", API_User)
    HTTPAjouteParamètre("CHKIMG", "api_secret", MDP)
    HTTPAjouteFichier("CHKIMG", "media", CheminImage, "application/octet-stream") // Aussi image/jpeg ou image/png
    SI PAS HTTPEnvoieFormulaire("CHKIMG", "https://api.sightengine.com/1.0/nudity.json", httpPost, "", "", typeMimeFormulaireMultiPartie) ALORS
        Erreur("Echec de l'envoi du formulaire : ", ErreurInfo())
    SINON
        vMonProduit est un Variant = JSONVersVariant(HTTPDonneRésultat())
        SI vMonProduit.status = "failure" ALORS
            LIB_Statut = ChaîneConstruit("Erreur : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
                vMonProduit.error.code,vMonProduit.error.type,vMonProduit.error.message)
        SINON
            LIB_Statut = ChaîneConstruit("Pas de nudité : %1"+[" "]+"Opérations : %5"+RC+"Nudité partielle : %2"+[" "]+"Média_Uri : %7"+RC+...
                "Nudité brute : %3"+[" "]+"Media_ID : %8"+RC+"Statut : %4"+[" "]+" Req_ID : %6",...
                vMonProduit.nudity.safe,vMonProduit.nudity.Partial,vMonProduit.nudity.raw,...
                vMonProduit.status,vMonProduit.operations,vMonProduit.request.id,vMonProduit.media.uri,vMonProduit.media.id)
        FIN
    FIN
    A+.
    Cliquez pour agrandir...
    Bonsoir

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    , un merci pour ton coup de pouce, je te suis reconnaissant. Ton code m'a permis de résoudre le problème juste en le modifiant je vous en verrai la version modifiée afin que quiconque aura le même problème que moi, trouvera solution.
     
    suenodesign apprécie ceci.
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28
    Code (Windev):
    CheminImage est une chaîne
    CheminImage =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (albumImage)
    IMG_Image = CheminImage
    SI CheminImage = "" ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
        RETOUR
    FIN
    /////////////////////////////////////////////////////////////////
    ////// Traitement de l'image/////////////////////////////

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG")

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "media", CheminImage,"application/octet-stream") // Aussi image/jpeg ou image/png application/octet-stream
    SI PAS

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "[URL]https://api.sightengine.com/1.0/nudity.json[/URL]", httpPost,"","","",API_User,MDP) ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Echec de l'envoi du formulaire : ",

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
    SINON
        sMonProduit est un Variant =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
    //    LIB_Statut = sMonProduit
        SI sMonProduit.status = "failure" ALORS
            LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Erreur : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
            sMonProduit.error.code,sMonProduit.error.type,sMonProduit.error.message)
         
        SINON
            LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Pas de nudité : %1"+RC+"Opérations : %5"+RC+"Nudité partielle : %2"+RC+"Média_Uri : %7"+RC+...
            "Nudité brute : %3"+RC+"Media_ID : %8"+RC+"Statut : %4"+RC+" Req_ID : %6",...
            sMonProduit.nudity.safe,sMonProduit.nudity.partial,sMonProduit.nudity.raw,...
            sMonProduit.status,sMonProduit.operations,sMonProduit.request.id,sMonProduit.media.uri,sMonProduit.media.id)
         
        FIN
    FIN
    /////////////////////////////////////////////////////////////////
     

    Fichiers attachés:

    #29 Man, Fev 19, 2019, à 10:05 AM
    Dernière édition par un modérateur: Fev 19, 2019, à 1:53 PM
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    105
    J'aime reçus:
    28
    Bonsoir, je viens à vous pour un compte-rendu à propos de mon sujet, qui ici a pu être résolu avec l'intervention de certains membres je cite ici

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    et

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    et bien d'autres membres.
    ////////// Code///////////////////////////////////////////////////////////////////////////
    Code (Windev):

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG")

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "media", CheminImage,"application/octet-stream") // Aussi image/jpeg ou image/png application/octet-stream
    SI PAS

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("CHKIMG", "[URL]https://api.sightengine.com/1.0/nudity.json[/URL]", httpPost,"","","",API_User,MDP) ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Failed to send the form :",

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ()+RC+"Try a solution : check your internet connection")
    // Afficher l'image par défaut
        IMG_Image = IMG_Image1
    SINON
        sMonProduit est un Variant =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ())
        Safe est un réel = sMonProduit.nudity.safe
        Raw est un réel = sMonProduit.nudity.raw
        Enpartie est un réel = sMonProduit.nudity.partial
        Statut est une chaîne = sMonProduit.status
        Tag est une chaîne = sMonProduit.nudity.partial_tag
        SI sMonProduit.status = "failure" ALORS
            LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Error : %1"+[" "]+"Type : %2"+RC+"Message : %3",...
            sMonProduit.error.code,sMonProduit.error.type,sMonProduit.error.message)
          // Afficher l'image par défaut
            IMG_Image = IMG_Image1
        SINON
            IMG_Image = CheminImage
            SI Safe>Raw _ET_ Safe>Enpartie ALORS
                LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Status : %1"+RC+"pas de nudité (%2), cette photo peut être publiée",Statut,Safe)
                LIB_Statut..Couleur = VertFoncé
                BTN_Appliquer..Opacité = 100
                BTN_Appliquer..Etat = Actif
                gsChemin = CheminImage
            SINON SI Raw>Safe _ET_ Raw>Enpartie ALORS
                LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Status : %1"+RC+...
                "This image is pornographic with a probability of %2. So can not be published",Statut,Raw)  
                LIB_Statut..Couleur = RougeFoncé
                BTN_Appliquer..Opacité = 40
                BTN_Appliquer..Etat = AffichageSeulement
                gsChemin = ""
            SINON SI Enpartie>Safe _ET_ Enpartie>Raw ALORS
                LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Status : %1"+RC+...
                "This image shows partial nudity with a probability of %2, the exposed part is : %3"+RC+...
                "Elle peut être publiée sous-réserve",Statut,Enpartie,Tag)  
                LIB_Statut..Couleur = GrisFoncé
                BTN_Appliquer..Opacité = 100
                BTN_Appliquer..Etat = Actif
                gsChemin = CheminImage
            SINON
                LIB_Statut =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Détails sur l'image à publier")  
                LIB_Statut..Couleur = GrisFoncé
                BTN_Appliquer..Opacité = 40
                BTN_Appliquer..Etat = AffichageSeulement
                gsChemin = ""
            FIN
        FIN
    FIN
     
    //////////////////// Fin ////////////////////////////////////////////////////////////////
    Une capture est jointe
     

    Fichiers attachés:

    #30 Man, Fev 19, 2019, à 1:40 PM
    Dernière édition par un modérateur: Fev 19, 2019, à 1:54 PM
    suenodesign et LAPIPE2018 aiment ça.
  • Partager cette page

    Chargement...