1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

Protéger votre logiciel avec un numéro de série

Discussion dans 'Windev' créé par suenodesign, Mar 17, 2018.

  1. suenodesign

    suenodesign Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    509
    J'aime reçus:
    739
    Protéger votre logiciel avec un


    Document réalisé par : Alibi Elmehdi
    Site web :

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Version du document : 2.0
    Date de publication : 03/09/2006
    [​IMG]
    Téléchargement

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Codes
    Code (Text):
    PROCEDURE genere(utilisateur)
     element,i est entier
      passe est une chaîne
    //ici on vérifie la taille du nom d’utilisateur
    SI Taille(utilisateur)<4 ALORS
    Warning("Le nom est trés court")
    RENVOYER Faux
    FIN
    element=0
    POUR i=1 A Taille(utilisateur)
    element =element*10+Asc(Milieu(utilisateur,i,1))
    element=modulo(element,65500)
    FIN
    passe=quatre_chiffres(element)+"-"
    element=0
    POUR i=1 A Taille(utilisateur)-1
    element=element+Asc(Milieu(utilisateur,i,1))+Asc(Milieu(utilisateur,i+1,1))
    element=modulo(element,65500)
    FIN
    passe=passe+quatre_chiffres(element)+"-"
    element=0
    POUR i=1 A Taille(utilisateur)-1
    element=element*10+Asc(Milieu(utilisateur,i-1,1))
    element=modulo(element,65500)
    FIN
    passe=passe+quatre_chiffres(element)+"-"
    element=0
    POUR i=1 A Taille(utilisateur)-2
    element=element+Asc(Milieu(utilisateur,Taille(utilisateur)-i,1))+Asc(Milieu(utilisateur,i+1,Taille(utilisateur)-i-11))
    element=modulo(element,65500)
    FIN
    passe=passe+quatre_chiffres(element)
    RENVOYER passe

    _____________________________________________________


    PROCEDURE quatre_chiffres(entree)
    i est entier
    inter est une chaîne
    inter =Gauche(entree,4)
    SI Taille(inter)<4 ALORS
    POUR i=Taille(inter) A 3
    inter+="7"
    FIN
    FIN
    RENVOYER inter
    J’espère que ce document servira à orienter votre réflexion.​
     
    Iron-Wolf-x, aminej76 et joker aiment ça.
  2. JHDSoft

    JHDSoft Member

    Inscrit:
    Mar 4, 2018
    Messages:
    41
    J'aime reçus:
    25
    salut tlm
    desole

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    mais c du n'importe quoi :)

    juste avec un seul nom d'utilisateur/pass tu peut le partager a tlm
     
  3. suenodesign

    suenodesign Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    509
    J'aime reçus:
    739
    @

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ,

    Tout essai d'innovation a son lot de vérité et de justesse comme il a ses faiblesses.

    Tout script quoique se soit sa complexité est le fruit d'une idée.

    N'imagine pas que les gens proposent du près à porter du premier essai.

    Alibi Elmehdi nous a permis de découvrir une méthode entre autres depuis 2006 à l'époque des lampes à pétrole et des bougies chez pczft.

    Je vous avoue que je vois mal ta critique envers quelqu'un qui a essayé d'aider. (je ne parle pas de moi mais de Elmehdi).

    Essayons ensemble d'être positifs.
    Ce script est un début de chemin.. Essayons de l'aménager et surtout d'y mettre des bouquets de fleurs.

    Merci de votre passage.
     
    joker apprécie ceci.
  4. JHDSoft

    JHDSoft Member

    Inscrit:
    Mar 4, 2018
    Messages:
    41
    J'aime reçus:
    25
    salam

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    1- j’espère que ta pas mal compris mon message je parle de toi ni de lui "Alibi" je parle de méthode elle même elle est des annee 90 cryptage d'un nom ou mail ou n'importe koi du client . je bien du tu peu partage ton nom/pass avec tlm.
    2- s 'il fait ca depuis 2006 c bien je suit pas contre mais aussi depuis 2007 ou 2008 je publier un un prog en publique demo pour 1 mois voila le

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    avec wd11 ou wd12 je me souvient plus vraiment avec un autre méthode est franchement au q1 problème jusqu a maintenant .
    3- petite conseil pour sécurité de vos programme n’utilise jamais même système de protégé pour vos prog , chaque programme a un methode de protege.


    petite remarque au procédure tu as pensée au 4 espace " " comme nom de client ?

    enfin merci a vous

    et désole encore une autre foi

    salam
     
    joker apprécie ceci.
  5. suenodesign

    suenodesign Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    509
    J'aime reçus:
    739
    Salam

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ,

    J'ai dû mal interpréter ton message, je m'en excuse. :oops:

    Pour le fait de changer de technique et de stratégie de protection et ne pas mettre tous les œufs dans le même panier chaque fois, Je suis totalement d'accord avec toi.

    Bon courage dud
     
    #5 suenodesign, Mar 18, 2018
    Dernière édition: Mar 18, 2018
    JHDSoft et joker aiment ça.

Partager cette page

Chargement...