1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

Protection Application Par DLL ' appel"

Discussion dans 'Windev' créé par RADOUANE999, Avr 22, 2018.

  1. RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    66
    J'aime reçus:
    18
    Bonjour
    je veux faire une protection pour mon application
    j ai trouve ce site

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    il propose une dll que donne le numero de serie du disk dur
    comme faire pour l utilise si j achet une licence
    je l ai utilise avec windev "AppelDLL32" mais a chaque utilisation il me dit que c'est une version demo
    il me faux un serial " comment faire pour l utilise " est entre le serial lors de l appel
    merci
     
  2. JHDSoft

    JHDSoft Member

    Inscrit:
    Mar 4, 2018
    Messages:
    41
    J'aime reçus:
    25

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    sans DLL
    windev propose fDisqueInfo() avec constante fdNuméroDeSérie
     
    joker apprécie ceci.
  3. WX1331

    WX1331 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 1, 2018
    Messages:
    611
    J'aime reçus:
    671
    Si je me rappelle il y avais un crack (Dll deja cracké) mais en cherchant aujourd’hui essaye ce serial :

    H81GK-F3YTS-PH6RW-UMM6N-6P477 F1PN3-T9W1C-5P2UM-91EL8-SPPH7

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    : GetDiskSerial renvoie le numéro du Disque Dur Constructeur tandis que fDisqueInfo() le numéro du disque qui une fois formaté il change.
     
    #3 WX1331, Avr 22, 2018
    Dernière édition par un modérateur: Déc 25, 2018
    JHDSoft et joker aiment ça.
  4. joker

    joker New Member
    MEMBRE WX

    Inscrit:
    Jan 30, 2018
    Messages:
    0
    J'aime reçus:
    14

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Si je me rappelle il y avais un crack (Dll deja cracké) mais en cherchant aujourd’hui essaye ce serial :

    H81GK-F3YTS-PH6RW-UMM6N-6P477 F1PN3-T9W1C-5P2UM-91EL8-SPPH7
    Cliquez pour agrandir...
    ThankS

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Cette clé fonctionne avec GetDiskSerial DLL v5.10 Released !
    téléchargée sur le lien du site donné par

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
    Fakirato apprécie ceci.
  • chitanous.dz

    chitanous.dz Member

    Inscrit:
    Jan 2, 2018
    Messages:
    14
    J'aime reçus:
    22
    wmic diskdrive 0 get serialnumber sous dos vous donne le numero de serie
     
    joker apprécie ceci.
  • WX1331

    WX1331 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 1, 2018
    Messages:
    611
    J'aime reçus:
    671
    Totalement raison WMI donne serial constructeur
     
  • joker

    joker New Member
    MEMBRE WX

    Inscrit:
    Jan 30, 2018
    Messages:
    0
    J'aime reçus:
    14

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    wmic diskdrive 0 get serialnumber sous dos vous donne le numero de serie
    Cliquez pour agrandir...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ,

    C'est idem fDisqueInfo() avec constante fdNuméroDeSérie
    ça donne le numéro de formatage
     
    elhacene apprécie ceci.
  • RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    66
    J'aime reçus:
    18

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Si je me rappelle il y avais un crack (Dll deja cracké) mais en cherchant aujourd’hui essaye ce serial :

    H81GK-F3YTS-PH6RW-UMM6N-6P477 F1PN3-T9W1C-5P2UM-91EL8-SPPH7
    Cliquez pour agrandir...
    mais comment faire pour déclare le serial lors de l " appel du dll
    de plus ce serial c'est pour l ancien version 3 ..la on est dans la version 5.10 ( w 7 et 8 et 10 )
     
    #8 RADOUANE999, Avr 22, 2018
    Dernière édition: Avr 22, 2018
  • WX1331

    WX1331 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 1, 2018
    Messages:
    611
    J'aime reçus:
    671
    non la Dll retourne le serial de
     
  • RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    66
    J'aime reçus:
    18

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    non la Dll retourne le serial de
    Cliquez pour agrandir...
    non je sais que elle retoune le serial du disque dur
    ce que je veux savoir c'est comment entree le numero de serie de la dll ( achete le numer de serie )
     
  • rezak

    rezak New Member
    DUMP TEAM

    Inscrit:
    Jan 22, 2018
    Messages:
    7
    J'aime reçus:
    5
    Bonsoir, j'ai trouvé un ancien projet a toute fin utile avec un fichier wfms.dll qui lit le numéro de série du disque et aussi celui du disque usb

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    pour télécharger l'exemple
     
  • Tamim

    Tamim Member
    MEMBRE WX

    Inscrit:
    Mar 30, 2018
    Messages:
    28
    J'aime reçus:
    32
    ce que je trouve marrant c'est vouloir protéger son appli en crackant une autre appli :)
    en tout cas voila aussi un vieux code

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
    joker apprécie ceci.
  • warjoen

    warjoen Active Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    157
    J'aime reçus:
    121
    I have Old GetDiskSerial versi 5.0 cracked
    It can run with windev
    I will be share soon

    Sorry to have to wait, because have to search in old data backup ....
    It's a link for GetDiskSerial.DLL :

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    GetDiskSerial.DLL in folder Release
    Example program in other program windev in folder Example
    Detail Procedure and function in folder Help

    I try with windev and run smoothly
    example code
    Trace(CallDLL32("GetDiskSerial.dll","GetSerialNumber",0))
     
    #13 warjoen, Avr 23, 2018
    Dernière édition par un modérateur: Déc 25, 2018
  • kabeda

    kabeda Active Member

    Inscrit:
    Avr 23, 2018
    Messages:
    173
    J'aime reçus:
    63
    Bonjour,
    Pour ce que ça vaut, je poste un bout de code. Je ne me rappelle plus la source.

    A savoir que ça ne fonctionne qu'à partir de Vista et >. Sur XP, ça renvoie une erreur.

    Ajouter d'abord RécupèreInfosLicence() en tant que procédure globale
    Code (Text):

    FONCTION RécupèreInfosLicence()

    objLocator est un objet Automation "WbemScripting.SWbemLocator"
    objService est un objet Automation dynamique
    Resultats est un objet Automation dynamique
    MonInfoLicence est une SuperInfoLicence

    QUAND EXCEPTION DANS
       objService = objLocator>>ConnectServer(".", "root\cimv2")
       objService>>Security_>>ImpersonationLevel = 3
     
       // Récupération du numéro de série du 1er disque
       Resultats = objService>>ExecQuery("SELECT SerialNumber,Tag FROM Win32_PhysicalMedia WHERE Tag LIKE '%PHYSICALDRIVE0'")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.NumSérieDisque = Resultats>>ItemIndex(x)>>Properties_>>Item("SerialNumber")>>Value
       FIN
         
       Resultats = objService>>ExecQuery("SELECT Name,UserName FROM Win32_ComputerSystem")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.RegisteredUser = Resultats>>ItemIndex(x)>>Properties_>>Item("UserName")>>Value
           MonInfoLicence.NamePC = Resultats>>ItemIndex(x)>>Properties_>>Item("Name")>>Value
       FIN  
       Resultats = objService>>ExecQuery("SELECT UUID FROM Win32_ComputerSystemProduct")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.UUID = Resultats>>ItemIndex(x)>>Properties_>>Item("UUID")>>Value
       FIN
       RENVOYER MonInfoLicence
     
    FAIRE
       Erreur("Erreur execution WMI",ExceptionInfo(errInfo))
       ExceptionActive()
       MonInfoLicence.Leresultat="Erreur WMI"
       RENVOYER MonInfoLicence
    FIN
     
    Il faudra d'abord faire une déclaration dans l’initialisation du projet
    Code (Text):

    SuperInfoLicence est une Structure
       NumSérieDisque est une chaîne
       NamePC est une chaîne
       RegisteredUser est une chaîne
       UUID est une chaîne
      Leresultat est une chaîne
    FIN
     
    Puis quelque part dans votre projet
    Code (Text):

    MonInfoLicence est une SuperInfoLicence

    MonInfoLicence=RécupèreInfosLicence()
    // Par exemple
    SI MonInfoLicence.Leresultat<>"Erreur WMI" ALORS
        info(MonInfoLicence.NumSérieDisque); // Pour le n° série du disque
        info(MonInfoLicence.UUID); // Pour l'identifiant unique de windows.
    FIN
     
    C'est juste un point d'entrée. A vous de voir quoi en faire.
     
    suenodesign, RADOUANE999 et joker aiment ça.
  • RADOUANE999

    RADOUANE999 Member

    Inscrit:
    Mar 21, 2018
    Messages:
    66
    J'aime reçus:
    18

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour,
    Pour ce que ça vaut, je poste un bout de code. Je ne me rappelle plus la source.

    A savoir que ça ne fonctionne qu'à partir de Vista et >. Sur XP, ça renvoie une erreur.

    Ajouter d'abord RécupèreInfosLicence() en tant que procédure globale
    Code (Text):

    FONCTION RécupèreInfosLicence()

    objLocator est un objet Automation "WbemScripting.SWbemLocator"
    objService est un objet Automation dynamique
    Resultats est un objet Automation dynamique
    MonInfoLicence est une SuperInfoLicence

    QUAND EXCEPTION DANS
       objService = objLocator>>ConnectServer(".", "root\cimv2")
       objService>>Security_>>ImpersonationLevel = 3
     
       // Récupération du numéro de série du 1er disque
       Resultats = objService>>ExecQuery("SELECT SerialNumber,Tag FROM Win32_PhysicalMedia WHERE Tag LIKE '%PHYSICALDRIVE0'")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.NumSérieDisque = Resultats>>ItemIndex(x)>>Properties_>>Item("SerialNumber")>>Value
       FIN
         
       Resultats = objService>>ExecQuery("SELECT Name,UserName FROM Win32_ComputerSystem")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.RegisteredUser = Resultats>>ItemIndex(x)>>Properties_>>Item("UserName")>>Value
           MonInfoLicence.NamePC = Resultats>>ItemIndex(x)>>Properties_>>Item("Name")>>Value
       FIN
       Resultats = objService>>ExecQuery("SELECT UUID FROM Win32_ComputerSystemProduct")
       POUR x = 0 _A_ Resultats>>Count -1
           MonInfoLicence.UUID = Resultats>>ItemIndex(x)>>Properties_>>Item("UUID")>>Value
       FIN
       RENVOYER MonInfoLicence
     
    FAIRE
       Erreur("Erreur execution WMI",ExceptionInfo(errInfo))
       ExceptionActive()
       MonInfoLicence.Leresultat="Erreur WMI"
       RENVOYER MonInfoLicence
    FIN
     
    Il faudra d'abord faire une déclaration dans l’initialisation du projet
    Code (Text):

    SuperInfoLicence est une Structure
       NumSérieDisque est une chaîne
       NamePC est une chaîne
       RegisteredUser est une chaîne
       UUID est une chaîne
      Leresultat est une chaîne
    FIN
     
    Puis quelque part dans votre projet
    Code (Text):

    MonInfoLicence est une SuperInfoLicence

    MonInfoLicence=RécupèreInfosLicence()
    // Par exemple
    SI MonInfoLicence.Leresultat<>"Erreur WMI" ALORS
        info(MonInfoLicence.NumSérieDisque); // Pour le n° série du disque
        info(MonInfoLicence.UUID); // Pour l'identifiant unique de windows.
    FIN
     
    C'est juste un point d'entrée. A vous de voir quoi en faire.
    Cliquez pour agrandir...
    Merci pour la source
     
  • Partager cette page

    Chargement...