1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

WM Problème de lenteur

Discussion dans 'Windev Mobile' créé par Man, Avr 10, 2019.

Tags:
  1. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    164
    J'aime reçus:
    34
    Bonjour je suis presque au bout car j'ai développé une application mobile avec WM23 une fois compilé l'accès aux interfaces devient très lent alors je vous soumis ici le code pour décrire ma connexion je vous le soumet à votre appréciation pour voir ce qui ne va pas.
    //////////////////////////////////////////////////////////////////////////////////////////////////////////////
    Code (Text):
    CnxHFCS est une Connexion
    CnxHFCS..Utilisateur = "User"
    CnxHFCS..MotDePasse = "mdp"
    CnxHFCS..Serveur = "Server_name"
    CnxHFCS..BaseDeDonnées = "BD_Name"
    CnxHFCS..Provider = hAccèsHFClientServeur
    CnxHFCS..Accès = hOLectureEcriture
    CnxHFCS..Cryptage = hCryptageRC5_16
    CnxHFCS..InfosEtendues = "Infos étendues "

    // Change la connexion des fichiers de l'application

    SI HChangeConnexion("*",CnxHFCS) =Faux ALORS
        Erreur("Impossible de changer la connexion", HErreurInfo(hErrMessage))
        FinProgramme(Vrai)
    FIN  

    // Création des fichiers
    SI HCréationSiInexistant("*",Web_Mdp)=Faux ALORS
        Erreur("Impossible de créer les fichiers de données", HErreurInfo(hErrMessage))
        FinProgramme(Vrai)
    FIN
    //Ouverture de la connexion MySQL
    SI HOuvreConnexion(CnxHFCS) = Faux ALORS
        Erreur("Impossible d'ouvrir la connexion", HErreurInfo(hErrMessage))
        FinProgramme(Vrai)
       
    FIN

    //Ouverture de la connexion MySQL
    SI HOuvreConnexion(CnxHFCS) = Faux ALORS
        Erreur("Impossible d'ouvrir la connexion", HErreurInfo(hErrMessage))
        FinProgramme(Vrai)
       
    FIN
    Merci
     
    Tags:
  2. naavgati

    naavgati New Member

    Inscrit:
    Avr 3, 2019
    Messages:
    2
    J'aime reçus:
    2
    Hi,

    Accessing HFSQL Client Server through mobile, always lead to delay. Because of direct data transfer over the internet.

    Better you use WebServices to access data from HFSQL Server.

    Regards,
     
    khaliassas et suenodesign aiment ça.
  3. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    164
    J'aime reçus:
    34

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Hi,

    Accessing HFSQL Client Server through mobile, always lead to delay. Because of direct data transfer over the internet.

    Better you use WebServices to access data from HFSQL Server.

    Regards,
    Cliquez pour agrandir...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    bonjour peux-tu me montrer comment faire un Web service surtout quand j'ai déjà mis en place une base données car faire un web service maintenant me prendrai le temps surtout que je ne maîtrise pas.
    Merci
     
  • suenodesign

    suenodesign Well-Known Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    426
    J'aime reçus:
    632
    Bonjour @

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Regarde ça :

     
    WX1331 apprécie ceci.
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    164
    J'aime reçus:
    34

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour @

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Regarde ça :

    Cliquez pour agrandir...
    Cool

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    je jette un coup d'oeil
     
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    164
    J'aime reçus:
    34

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Je vous assure je viens de suivre le tuto mais je t'assure que c'est pas facile.
     
  • naavgati

    naavgati New Member

    Inscrit:
    Avr 3, 2019
    Messages:
    2
    J'aime reçus:
    2

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Let me know if you face any difficulties in web service implementation.
     
  • Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    164
    J'aime reçus:
    34

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Let me know if you face any difficulties in web service implementation.
    Cliquez pour agrandir...
    Bonjour

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    j'éprouve les difficultés malgré la vidéo que

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    a bien voulu mettre à ma disposition. Je n'ai jamais eu à mettre en place un Web Service.

    si vous pouvez m'aider je serai heureux.
    Merci
     
  • Partager cette page

    Chargement...