1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

WB Problème de communication avec l'API

Discussion dans 'Sujets Divers' créé par Man, Août 13, 2019.

  1. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    212
    J'aime reçus:
    43
    Bonjour les FEKWX
    [webdev 23][Débutant]
    Je suis entrain de développer un Webservice de type REST que je consommerai dans mes applications cliente. Mon premier blocage est sur l'application cliente : Application Web où je ne parviens pas à me connecter à mon Webservice.
    Je soumets ici le code du Webservice et le code que j'utilise pour appeler ce Webservice
    Code (Windev):

    PROCÉDURE UtilisateurConnecte(): chaîne

    stLogin est un STLogin
    bufContenu est un Buffer

    xLog("UtilisateurConnecte")

    // utilisateur
    bufContenu = WebserviceParamètre(paramBuffer)
    SI bufContenu = "" ALORS
        xLog("Contenu vide",Vrai)
        RENVOYER ""
    FIN

    // Deserialisation

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (stLogin,bufContenu,psdJSON)

    SI stLogin.sNumTel ~= ""  ALORS
        xLog("sLogin vide",Vrai)
        RENVOYER ""
    FIN
    SI stLogin.sMotDePasse ~= "" ALORS
        xLog("sMotDePasse vide",Vrai)
        RENVOYER ""
    FIN
    // Vérification du couple

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (Users,NumTel,stLogin.sNumTel,hIdentique)
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (Users) _ET_ Users.Mdp = HashMotDePasse(stLogin.sMotDePasse) ALORS
         xLog("Connexion Ok : "+ Users.IDUsers+ "_" + Users.TokenConnexion + "_" + Users.Cat_User,Faux)
         RENVOYER Users.IDUsers+ "_" + Users.TokenConnexion + "_" + Users.Cat_User
         SINON
         xLog("Connexion pas Ok : "+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (Users)+ "_" + stLogin.sMotDePasse,Vrai)  
         RENVOYER ""
    FIN

    CAS ERREUR:
    xLog("UtilisateurConnecte:"+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (),Vrai)
    RENVOYER ""
    CAS EXCEPTION:
    xLog("UtilisateurConnecte:"+

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (),Vrai)
    RENVOYER ""
    Code qui appelle mon Webservice
    Code (Windev):
    PROCÉDURE WS_UtilisateurConnect(pCallback est une Procédure, sLogin est une chaîne , sMotDePasse est une chaîne)

    maRequete est un restRequête
    maReponse est une restRéponse
    stLogin est un STLogin

    // URL
    maRequete.Méthode = httpPost
    maRequete.ContentType = typeMimeJSON
    maRequete.URL = URL_WS() + ["/"] + "user/connect"

    // Contenu
    stLogin.sNumTel = sLogin
    stLogin.sMdp = sMotDePasse
    bufContenu est un Buffer

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (stLogin,bufContenu,psdJSON)
    maRequete.Contenu = bufContenu

    // Requête
    maReponse = RESTEnvoie(maRequete)

    // Traitement de la réponse
    SI

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    _OU_ maReponse.CodeEtat <> 200 ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (pCallback,Faux,ERR_RESEAU)
        RETOUR
    FIN
    // Récupération des infos
    sReponse est une chaîne =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (maReponse..Contenu)

    nID est un entier =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (sReponse,1,"_")
    PAGE_Indra.ZTR_1 = nID
    sToken est une chaîne =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (sReponse,2,"_")
    Type est un entier =

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (sReponse,3,"_")
    SI nID <= 0 _OU_ sToken ~= "" ALORS
       

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (pCallback,Faux,

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ("Erreur %1 : Erreur d'authentification"+...
        ". Merci de vérifier votre Pseudo ou votre mot de passe",...
        NOT_FOUND))
        RETOUR
    FIN


    // Sauvegarde
    gnUSER_ID = nID
    gsUSER_Token = sToken
    gsTypeUser = Type

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (pCallback,Vrai, "")
    La structure
    Code (Windev):
    STUsers est une Structure
        nIDUsers                     est un entier sur 8 octets            <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "IDUser">
        sNomComplet                 est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Nom">
        sPays                         est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Pays">
        dhInscrit_Le                 est une DateHeure         <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ="Inscrit_le">
        sNumTel                     est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Tel">
        sPhoto_User                 est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Avatar">
        nCat_User                     est un entier             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Type_Utilisateur">
        IDPhone                     est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "IDPhone">
        bAutorisé                     est un booléen             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Autorized">
    FIN
    //////// Structure de Login ////////////////////////////////
    STLogin est une Structure
        sNumTel                     est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Login">
        sMotDePasse                 est une chaîne             <

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    = "Mdp">
    FIN
    Je joins aussi les différentes captures d'écran.
    Je me tiens disponible à toute solution proposée.
    Merci d'avance
     

    Fichiers attachés:

  2. zoomeo

    zoomeo New Member

    Inscrit:
    Fev 2, 2018
    Messages:
    1
    J'aime reçus:
    0
    Bonjour,

    Qu'as tu comme code erreur et message d'erreur côté mobile ?
    Es-tu sûr de ton URL ?
    As-tu créer une description pour ton webservice Rest dans ton projet webdev ?
     
  3. Man

    Man Active Member

    Inscrit:
    Juil 9, 2018
    Messages:
    212
    J'aime reçus:
    43

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour,

    Qu'as tu comme code erreur et message d'erreur côté mobile ?
    Es-tu sûr de ton URL ?
    As-tu créer une description pour ton webservice Rest dans ton projet webdev ?
    Cliquez pour agrandir...
    Bonjour

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    J'ai fais tout ce que vous demandez, mais quand j'exécute dans le fichier Log l'erreur est la suivante : Login vide
     
  • haythem

    haythem New Member

    Inscrit:
    Août 3, 2018
    Messages:
    4
    J'aime reçus:
    3
    Salut,

    essayer bufContenu est une chaine au lieu de bufContenu est un Buffer dans le code d'appel du web service et dans le code du web service.
    sera bie d'ajouter aussi un log sur les variable buffer
     
  • Partager cette page

    Chargement...