1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

Killer l'application TEAMVIEWER

Discussion dans 'Windev' créé par gapplicat, Mar 27, 2018.

  1. gapplicat

    gapplicat Well-Known Member
    MEMBRE WX

    Inscrit:
    Mar 8, 2018
    Messages:
    398
    J'aime reçus:
    679
    Dans le cadre de l'assistance avec nos clients, nous sommes souvent confrontés à des installations de Teamviewer de différentes versions.

    Avec ces deux procédures nous pouvons arrêter les processus TEAMVIEWER afin de pouvoir relancer notre TeamViewer avec notre version...


    Code (Text):

    PROCEDURE AfficheProcessus()

    ListeSupprimeTout(LISTE_IDPROCESSUS)
    ListeSupprimeTout(LISTE_PROCESSUS)

    ListeAjoute(LISTE_PROCESSUS,ExeListeProcessus(exeNomCourt,exePID))

    POUR I = 1 A ListeOccurrence(LISTE_PROCESSUS)
        SI ChaîneOccurrence(LISTE_PROCESSUS[I],"TeamViewer") <> 0 ALORS ListeAjoute(LISTE_IDPROCESSUS,ExtraitChaîne(LISTE_PROCESSUS[I],2,TAB))
        SI ChaîneOccurrence(LISTE_PROCESSUS[I],"tv_w32") <> 0 ALORS ListeAjoute(LISTE_IDPROCESSUS,ExtraitChaîne(LISTE_PROCESSUS[I],2,TAB))
        SI ChaîneOccurrence(LISTE_PROCESSUS[I],"tv_x64") <> 0 ALORS ListeAjoute(LISTE_IDPROCESSUS,ExtraitChaîne(LISTE_PROCESSUS[I],2,TAB))
    FIN

     
    Code (Text):

    PROCEDURE KilllesProcessus()
    Nfic est un entier
    //Tue le processus TeamViewer

    fRepCrée(fRepExe()+"\Utilitaires\")


    POUR I = 1 A ListeOccurrence(LISTE_IDPROCESSUS)
        Nfic = fOuvre(fRepExe()+"\Utilitaires\KillProcess.cmd",foCréation+foAjout)
        SI Nfic <> -1 ALORS
            fEcritLigne(Nfic,"TASKKILL /PID " + SansEspace(LISTE_IDPROCESSUS[I]) + " /F")
            fFerme(Nfic)
           
            LanceAppli(fRepExe()+"\Utilitaires\KillProcess.cmd", exeIconise, exeBloquant)
            SI ErreurDétectée ALORS  
                Erreur()
            FIN
        FIN  
        //Multitâche(100)
    FIN

     
    et le code source (WD20) :

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
  2. elhacene

    elhacene Active Member
    MEMBRE WX

    Inscrit:
    Jan 14, 2018
    Messages:
    288
    J'aime reçus:
    147
    ayy tu l a fait avec la version w22 :confused:, je me suis pas encore sortie avec cette version , mais si tu descend à la w20:D:rolleyes:;
     
  3. gapplicat

    gapplicat Well-Known Member
    MEMBRE WX

    Inscrit:
    Mar 8, 2018
    Messages:
    398
    J'aime reçus:
    679
    Tu pourras t'en sortir avec les codes....:)
     
  4. joker

    joker New Member
    MEMBRE WX

    Inscrit:
    Jan 30, 2018
    Messages:
    0
    J'aime reçus:
    9
    @

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Tu fais Copié / Coller du code

    PS : ne fais pas 1 Copié / Coller de @

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
    elhacene et Deft54 aiment ça.
  5. cobracb

    cobracb New Member

    Inscrit:
    Août 30, 2018
    Messages:
    1
    J'aime reçus:
    0
    Merci beaucoup.
    S'il vous plaît, un exemple pratique...
     

Partager cette page

Chargement...