1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

AIDE Gestion de perte de connexion sur une application Android

Discussion dans 'Windev Mobile' créé par RayMM, Août 27, 2020.

  1. RayMM

    RayMM Member

    Inscrit:
    Mar 3, 2018
    Messages:
    39
    J'aime reçus:
    6
    Bonjour à tous,
    Je veux faire une gestion de la perte de connexion HFSQL sur une application Android, pour cela j'utilise les fonctions HSurErreur et HReconnecte.
    Mais quand je fait un test (je coupe la connexion sur mon device) l'erreur "La communication avec le serveur <...> a échoué" est remonté au niveau de la fonction HReconnecte
    une idée svp ?

    initialisation du projet :
    HSurErreur("*", hErrPerteConnexion, reconnexionHF)

    Procédure reconnexionHF :
    HReconnecte()
    SI ErreurDétectée ALORS
    ToastAffiche("Erreur")
    SINON
    ToastAffiche("Ok")
    FIN
    RENVOYER opRéessayer
     
  2. RayMM

    RayMM Member

    Inscrit:
    Mar 3, 2018
    Messages:
    39
    J'aime reçus:
    6
    Le problème est du à l'utilisation d'un thread secondaire au niveau de ma procédure principale (qui contient les fonctions HFSQL)
    La gestion de la perte de connexion HFSQL fonctionne bien quand j'ai enlevé ce thread !
    qu'est ce que vous pensez ?

    (à noter qu'il y a un exemple complet dans la LST 109 qui montre comment gérer les connexions à un serveur HFSQL depuis une application mobile)
     
  3. dohmien

    dohmien Member

    Inscrit:
    Juin 14, 2018
    Messages:
    85
    J'aime reçus:
    32
    Dans ta procédure de reconnexion tu devrais modifier les valeurs renvoyées je pense :

    Procédure reconnexionHF :
    HReconnecte()
    SI ErreurDétectée ALORS
    ToastAffiche("Erreur")
    RENVOYER opAnnuler
    SINON
    ToastAffiche("Ok")
    RENVOYER opRéessayer
    FIN
     
    investdatasystems apprécie ceci.

Partager cette page

Chargement...