1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

AIDE Fichier HFSQL récalcitrant

Discussion dans 'Résolution problème & conseils' créé par Bip_bip, Juil 21, 2020.

  1. Bip_bip

    Bip_bip Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    43
    J'aime reçus:
    26
    Bonjour,
    Je vais tenter d'expliquer mon souci...
    J'ai créé plusieurs fichiers .FIC dans ma base de donnée decrits dans mon analyse, à l'ouverture de mon application je fait bien un HDécritConnexion (ou je spécifie le chemin réseau ou sont tous les fichiers), puis un hOuvreConnexion.

    La description de chaque fichier est sur <Répertoire défini au niveau de l'analyse> sauf 1 qui est sur <Répertoire de l'application>.

    J'ai un fichier Utilisateur.fic qui est sur <Répertoire défini au niveau de l'analyse> qui se créée a chaque ouverture de mon application dans le répertoire de l'application au lieu de se trouver avec les autres dans le chemin réseau spécifié.

    Tous les fichiers fonctionnent bien lorsque je les sollicites (sans appliquer HchangeConnexion)

    Ce fichier Utilisateur.fic, je l'ai effacé et créé une 2eme fois dans l'analyse, mais il ne veux rien savoir il se met tjrs ds le répertoire de l'application...

    Quand je vais dans WDOptimiseur ouvrir le REP, il indique les 2 chemins dont celui du répertoire de l'application en indiquant que le fichier est inexistant.
    Je le supprime du REP, il se recrée automatiquement au prochain demarrage et figure a nouveau avec le chemin erroné dans le REP.

    Quelle solution pour résoudre ce souci...?
    Est ce un bug..? Qqun a déjà eu ce souci...?

    Sinon je vais le supprimer et le refaire avec un autre nom....

    Qu'en pensez vous...?

    Bip Bip...
     
  2. LAPIPE2018

    LAPIPE2018 Active Member
    MEMBRE WX

    Inscrit:
    Fev 17, 2018
    Messages:
    482
    J'aime reçus:
    193
    Cherches les fichiers .REP et tu les effaces
     
  3. Bip_bip

    Bip_bip Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    43
    J'aime reçus:
    26
    Alors j'ai effacé les .rep, mais le souci perdure.
    Lorsque je vais dans le centre de contrôle HFSQL, je vois bien le fichier Utilisateur mais qui n'est pas dans le bon répertoire et je n'ai pas moyen de modifier le chemin a ce niveau...
     
  4. Bip_bip

    Bip_bip Member
    MEMBRE WX

    Inscrit:
    Jan 1, 2018
    Messages:
    43
    J'aime reçus:
    26
    Hello, je pense que mon analyse est corrompue, je vais devoir tout recommencer....grrr
     

Partager cette page

Chargement...