1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

EXTRAIT DE CHAINE

Discussion dans 'Windev' créé par faloudja, Mar 25, 2020.

  1. faloudja

    faloudja New Member

    Inscrit:
    Juin 16, 2018
    Messages:
    28
    J'aime reçus:
    4
    Bonjour à tous
    jai un texte dans un champ de saisie
    AZERTNOLMP0987654DFGH
    je cherche à extrait la chaine dans le de saisie et le scinder en groupe de 4 caracteres

    merci de votre aide
     
    Tags:
  2. Gemini1961

    Gemini1961 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 2, 2018
    Messages:
    251
    J'aime reçus:
    481
    Bonjour

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Voici un lien qui répondra certainement à ta demande :)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Bien cordialement
     
  3. faloudja

    faloudja New Member

    Inscrit:
    Juin 16, 2018
    Messages:
    28
    J'aime reçus:
    4

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Voici un lien qui répondra certainement à ta demande :)

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Bien cordialement
    Cliquez pour agrandir...
    merci
     
  • Gemini1961

    Gemini1961 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 2, 2018
    Messages:
    251
    J'aime reçus:
    481

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Pour le Fun :)

    FONCTION Chaine_Decoupe ( p_sChaineSource est une chaîne ...
    , p_nTailleDesMorceaux est un entier ...
    , p_sSeparateur est une chaîne = TAB ...
    , p_bErreur = Faux) : chaîne
    LOCAL
    sChaineSource est une chaîne = p_sChaineSource
    nTailleSource est un entier = Taille(sChaineSource)
    sChaineDecoupee est une chaîne = ""
    sSeparateur est une chaîne = p_sSeparateur
    nTailleDesMorceaux est un entier = p_nTailleDesMorceaux
    nPosition est un entier

    SI nTailleSource = 0 _OU_ nTailleDesMorceaux < 1 ALORS
    p_bErreur = Vrai
    SINON

    nPosition = 1
    TANTQUE nPosition < nTailleSource
    sChaineDecoupee+= Milieu(sChaineSource,nPosition,nTailleDesMorceaux) + sSeparateur
    nPosition += nTailleDesMorceaux
    FIN
    FIN

    RENVOYER(sChaineDecoupee)
     
    netrad apprécie ceci.
  • Hartyshow

    Hartyshow Member

    Inscrit:
    Août 10, 2018
    Messages:
    34
    J'aime reçus:
    9
    Code (Text):

    CONSTANT
        PAR_4    = 4
    FIN
    // Variables
    MaChaîne est une chaîne = "AZERTNOLMP0987654DFG"
    SousChaine est une chaîne
    i est un entier = 1

    // Parcours du champ
    TANTQUE i <= Taille(MaChaîne)
        SousChaine = MaChaîne[[i A i + PAR_4 - 1]]
        Trace(SousChaine)
        i += PAR_4
    FIN
     
     
  • Gemini1961

    Gemini1961 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 2, 2018
    Messages:
    251
    J'aime reçus:
    481

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Je suppose que lorsque tu auras besoin d'une découpe par 5, il n'y aura que quelqu'un caractère à changer .... tel que " Par_4 = 5 " :)

    Bien cordialement
     
  • Hartyshow

    Hartyshow Member

    Inscrit:
    Août 10, 2018
    Messages:
    34
    J'aime reçus:
    9

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Il est vrai que TAILLE_PAR_MORCEAU = 4 aurait été plus beau !

    Mais mon intervention était de donner une alternative à votre solution, pas un concours "de savoir qui a la plus longue !"

    Bien cordialement.
     
  • Gemini1961

    Gemini1961 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 2, 2018
    Messages:
    251
    J'aime reçus:
    481

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!



    Loin de moi cette idée de concours ...

    Ton code répond parfaitement à la demande ... le mien est plus générique ...

    Si mes remarques t'ont blessé, je m'en excuse profondément

    Au plaisir de te lire à nouveau .

    Bien cordialement
     
    suenodesign apprécie ceci.
  • Dalida20

    Dalida20 New Member

    Inscrit:
    Fev 16, 2018
    Messages:
    25
    J'aime reçus:
    17
    Bravo à tous !:angel:
     
    Gemini1961 apprécie ceci.
  • faloudja

    faloudja New Member

    Inscrit:
    Juin 16, 2018
    Messages:
    28
    J'aime reçus:
    4
    BRAVO A VOUS PROBLÈME RÉGLÉ

    UN GRAND MERCI A VOUS TOUS
     
    Gemini1961 apprécie ceci.
  • Partager cette page

    Chargement...