1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

DISCUTIONS INSTANTANÉ

Discussion dans 'Windev Mobile' créé par rolandprime, Mai 31, 2019.

  1. rolandprime

    rolandprime New Member

    Inscrit:
    Mai 13, 2018
    Messages:
    17
    J'aime reçus:
    10
    Bonjour a tous les Fekwx je voudrais que vous m'aidez a créé une discutions instantané avec windev mobile .

    Mais voilà ce que je veux faire quand une personne mais une annonce . une personne peut rentre dans son inbox et le répondre sur son annonce .

    et ce que je veux l'annonce posté ne doit pas être vue pas tout le monde elle doit être vue seulement si je suis dans la même zone avec celui qui la posté .
     
  2. popoy

    popoy Well-Known Member
    MEMBRE WX

    Inscrit:
    Fev 23, 2018
    Messages:
    1,473
    J'aime reçus:
    845
    hum,
    ça ressemble fortement a un projet de

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    fait une recherche sur le forum , sa copie de debut de projet est peut être encore en partage.
     
  3. WX1331

    WX1331 Well-Known Member
    MEMBRE WX DUMP TEAM

    Inscrit:
    Jan 1, 2018
    Messages:
    487
    J'aime reçus:
    556
    SAlut mes Amis Trolls

    Oui c'est vrai déjà fait ça dans un réseau local en utilisant les sockets entre un PC et les autres (PC+Smartphone).
    Voila comment j'ai procédé

    Partie WM
    bufSMessage est un Buffer=SAI_Message

    SI PAS SocketExiste("Serveur") ALORS
    SI SocketConnecte("Serveur",6001,"192.168.1.100",1000) = Faux ALORS
    Erreur("erreur de connexion " + ErreurInfo(errMessage))
    SINON
    SI SocketEcrit("Serveur",UnicodeVersAnsi(bufSMessage)) = Vrai ALORS // SI SocketEcrit("Serveur", bufSMessage,"192.168.56.1",6001)
    Info("message envoyé")
    SINON
    Info("message non envoyé")
    FIN

    SocketFerme("Serveur")
    FIN
    SINON
    SI SocketEcrit("Serveur",UnicodeVersAnsi(bufSMessage)) = Vrai ALORS // SI SocketEcrit("Serveur", bufSMessage,"192.168.56.1",6001)
    Info("message envoyé")
    SINON
    Info("message non envoyé")
    FIN
    FIN

    Partie WD //Créer une fenetre d'identification
    SI SocketExiste("Serveur") = Faux ALORS
    SI SocketCrée("Serveur",SAI_NumPortIn,COMBO_AdresseIP..Valeur) = Faux ALORS
    Erreur("Erreur création " + ErreurInfo(errMessage))
    SINON
    BTN_Connecter..Etat=Grisé
    BTN_Déconnecter..Etat=Actif
    ThreadExécute("Thread1", threadNormal, ProcédureAttente)
    FIN
    FIN

    PROCEDURE ProcédureAttente()
    BOUCLE
    Multitâche(0)
    SI SocketAttendConnexion("Serveur") = Vrai ALORS
    Canal est une chaîne
    // Si la connexion est acceptée,
    // la gestion de cette connexion est réalisée dans un thread spécifique
    Canal = SocketAccepte("Serveur")
    ThreadExécute(Canal, threadNormal, ProcédureGestion, Canal)
    FIN
    FIN

    // Procédure automatique :
    // La procédure est exécutée manuellement, lors d'un appel dans le code
    // Elle s'exécutera dans un thread (sans avoir besoin d'appeler la fonction ThreadExecute), sans utilisation de HFSQL
    //
    PROCEDURE ProcédureGestion(LeCanal)
    //Info("Bravo connecté")

    TANTQUE SocketExiste(LeCanal)

    QUAND EXCEPTION DANS
    sData est une chaîne = SocketLit(LeCanal, Vrai) //Lance une exception
    // SI SocketChangeModeTransmission("Serveur", SocketTailleDébut) = faux ALORS
    // Info("Mode de transmission modifié")
    // FIN
    Trace("RECU="+sData+" "+SocketClientInfo(LeCanal,SocketAdresse))
    FAIRE
    //ErreurInfo() ne retourne rien.
    FIN

    FIN
     
    michel et suenodesign aiment ça.
  4. rolandprime

    rolandprime New Member

    Inscrit:
    Mai 13, 2018
    Messages:
    17
    J'aime reçus:
    10

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Partie
    Cliquez pour agrandir...
    cool
     

Partager cette page

Chargement...