1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Bonjour tout le monde ! Veillez consulter la Politique de forum pour comprendre nos règles, Merci a vous !
    Rejeter la notice

DEMANDE la requête a été exécuté plusieurs fois avec les même paramétrés dans la même minute

Discussion dans 'Windev' créé par Safo, Mai 17, 2020.

Tags:
  1. Safo

    Safo New Member

    Inscrit:
    Mai 1, 2018
    Messages:
    4
    J'aime reçus:
    0
    salut a tous
    j'ai ce message la requête a été exécuté plusieurs fois avec les même paramétrés dans la même minute

    tout fonctionne parfaitement mais quand je ferme la Fenetre de test le projet , je reçois ce message
     

    Fichiers attachés:

    • req.png
      req.png
      Taille de fichier:
      12.5 KB
      Affichages:
      18
    Tags:
  2. kabeda

    kabeda Active Member

    Inscrit:
    Avr 23, 2018
    Messages:
    121
    J'aime reçus:
    57
    Bonjour,
    Pour avoir reçu le même souci, je ne peux que te dire : Trouves une autre méthode d'accès à tes données. Si tu ignores ce message, tu va te retrouver avec des bugs. Pour mon cas c'était à l'impression.
    Essayes d'éviter, si tu peux, l'utilisation d'une requête à ce niveau du programme.
     
  3. faucon_tunisien

    faucon_tunisien New Member

    Inscrit:
    Déc 13, 2019
    Messages:
    11
    J'aime reçus:
    2
    bjr
    il faut utiliser

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!


    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

     
    amberass et mikee5 aiment ça.
  4. amberass

    amberass Member

    Inscrit:
    Avr 12, 2020
    Messages:
    32
    J'aime reçus:
    7

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    bjr
    il faut utiliser

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Cliquez pour agrandir...
    Bien vue mais a mon avis. seul problème cela ne va pas forcement résoudre le problème si tu le met avant l'affichage d'un etat aussi, cela va générer un warning qui est le vidage des données en mémoire donc ton état va retourner aucune valeur trouver.
     
  • /su

    /su New Member

    Inscrit:
    Avr 22, 2020
    Messages:
    10
    J'aime reçus:
    1
    le resultat et la meme ou pas
    si ouivous pouvez utiliser redis
     
  • Dandypunk

    Dandypunk Member

    Inscrit:
    Nov 28, 2019
    Messages:
    91
    J'aime reçus:
    24
    Bonjour,
    Que donne :
    Code (Windev):

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat)
    //L'utilisation de HLibèreRequête après le TableAffiche risque de fausser le résultat car le remplissage du champ se fait en tâche de fond
    REQ_Achat.Param1=ValeurParam1
    ...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat,taReExécuteRequete)
     
    Par ailleurs, où se trouve ton code. Cela peut influer, surtout s'il se trouve dans le code de sélection d'une de tes combos.
    Tu sélectionnes les 3 conditions, tu exécutes la requête 3 fois.
     
    #6 Dandypunk, Mai 24, 2020, à 9:20 AM
    Dernière édition: Mai 24, 2020, à 9:31 AM
  • Safo

    Safo New Member

    Inscrit:
    Mai 1, 2018
    Messages:
    4
    J'aime reçus:
    0

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour,
    Que donne :
    Code (Windev):

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat)
    //L'utilisation de HLibèreRequête après le TableAffiche risque de fausser le résultat car le remplissage du champ se fait en tâche de fond
    REQ_Achat.Param1=ValeurParam1
    ...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat,taReExécuteRequete)
     
    Par ailleurs, où se trouve ton code. Cela peut influer, surtout s'il se trouve dans le code de sélection d'une de tes combos.
    Tu sélectionnes les 3 conditions, tu exécutes la requête 3 fois.
    Cliquez pour agrandir...
    Bonjour. c'est mon code je l'ai mis dans la sélection d'une ligne de chaque combo ma table est reliée a la Requête.
    le résultat est parfait mais quand je ferme le débogueur je reçois ce message j'ai utilisé le "

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    " mais le même message Dans le débogueur
    est-il possible de filtrer les donnes dans la "table reliée a fichier" j'ai combo avec 1er ligne personnalisée "Tout" est entre 2 date ?

    SI COMBO_Type=1 ALORS
    TABLE_Commande..Visible=Vrai
    TABLE_Réception..Visible=Faux
    Command()
    NBRCommande()
    Message(" "+"Les Bons De Commande"+" ")
    FIN
    //***********************Réception***********************************************
    SI COMBO_Type=2ALORS


    BonRéception()
    NBRéception()
    TABLE_Réception..Visible=Vrai
    TABLE_Commande..Visible=Faux
    Message(" "+"Les Bons De Réception"+" ")
    FIN



    PROCÉDURE BonRéception()

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN



    PROCÉDURE NBRéception()
    nb est un entier = TableOccurrence(TABLE_Réception)
    POUR i = 0 À nb
    sInfo est une chaîne
    sInfo="Les Bons De Réception"+" "+"("+i+")"
    LIB_SansNom1=sInfo
    FIN
    SI nb<=0 ALORS
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
    RETOUR
    SINON
    TableTrie(TABLE_Réception,"-col_Date" )
    TableTrie(TABLE_Réception,"-col_Heure")
    FIN
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
     

    Fichiers attachés:

    • 123.png
      123.png
      Taille de fichier:
      6.2 KB
      Affichages:
      2
  • Safo

    Safo New Member

    Inscrit:
    Mai 1, 2018
    Messages:
    4
    J'aime reçus:
    0

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    Bonjour,
    Que donne :
    Code (Windev):

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat)
    //L'utilisation de HLibèreRequête après le TableAffiche risque de fausser le résultat car le remplissage du champ se fait en tâche de fond
    REQ_Achat.Param1=ValeurParam1
    ...

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    (REQ_Achat,taReExécuteRequete)
     
    Par ailleurs, où se trouve ton code. Cela peut influer, surtout s'il se trouve dans le code de sélection d'une de tes combos.
    Tu sélectionnes les 3 conditions, tu exécutes la requête 3 fois.
    Cliquez pour agrandir...
    Bonjour. c'est mon code je l'ai mis dans la sélection d'une ligne de chaque combo ma table est reliée a la Requête.
    le résultat est parfait mais quand je ferme le débogueur je reçois ce message j'ai utilisé le "

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    " mais le même message Dans le débogueur
    est-il possible de filtrer les donnes dans la "table reliée a fichier" j'ai combo avec 1er ligne personnalisée "Tout" est entre 2 date ?

    SI COMBO_Type=1 ALORS
    TABLE_Commande..Visible=Vrai
    TABLE_Réception..Visible=Faux
    Command()
    NBRCommande()
    Message(" "+"Les Bons De Commande"+" ")
    FIN
    //***********************Réception***********************************************
    SI COMBO_Type=2ALORS


    BonRéception()
    NBRéception()
    TABLE_Réception..Visible=Vrai
    TABLE_Commande..Visible=Faux
    Message(" "+"Les Bons De Réception"+" ")
    FIN


    PROCÉDURE BonRéception()

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    PROCÉDURE NBRéception()
    nb est un entier = TableOccurrence(TABLE_Réception)
    POUR i = 0 À nb
    sInfo est une chaîne
    sInfo="Les Bons De Réception"+" "+"("+i+")"
    LIB_SansNom1=sInfo
    FIN
    SI nb<=0 ALORS
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
    RETOUR
    SINON
    TableTrie(TABLE_Réception,"-col_Date" )
    TableTrie(TABLE_Réception,"-col_Heure")
    FIN
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
     
  • Safo

    Safo New Member

    Inscrit:
    Mai 1, 2018
    Messages:
    4
    J'aime reçus:
    0
    Bonjour. c'est mon code je l'ai mis dans la sélection d'une ligne de chaque combo ma table est reliée a la Requête.
    le résultat est parfait mais quand je ferme le débogueur je reçois ce message j'ai utilisé le "

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    " mais le même message Dans le débogueur
    est-il possible de filtrer les donnes dans la "table reliée a fichier" j'ai combo avec 1er ligne personnalisée "Tout" est entre 2 date ?

    SI COMBO_Type=1 ALORS
    TABLE_Commande..Visible=Vrai
    TABLE_Réception..Visible=Faux
    Command()
    NBRCommande()
    Message(" "+"Les Bons De Commande"+" ")
    FIN
    //***********************Réception***********************************************
    SI COMBO_Type=2ALORS


    BonRéception()
    NBRéception()
    TABLE_Réception..Visible=Vrai
    TABLE_Commande..Visible=Faux
    Message(" "+"Les Bons De Réception"+" ")
    FIN


    PROCÉDURE BonRéception()

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs<>"Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Utilisateurs..ValeurAffichée,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement="Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,COMBO_Fourniosseur,Null,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    SI COMBO_Fourniosseur="Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,Null,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN

    PROCÉDURE NBRéception()
    nb est un entier = TableOccurrence(TABLE_Réception)
    POUR i = 0 À nb
    sInfo est une chaîne
    sInfo="Les Bons De Réception"+" "+"("+i+")"
    LIB_SansNom1=sInfo
    FIN
    SI nb<=0 ALORS
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
    RETOUR
    SINON
    TableTrie(TABLE_Réception,"-col_Date" )
    TableTrie(TABLE_Réception,"-col_Heure")
    FIN
    SAI_Total=TABLE_Réception.COL_TotalTTC[ligneTotal]
    SAI_Reste=TABLE_Réception.COL_Rest[ligneTotal]
     
  • FreudWD

    FreudWD Well-Known Member
    MEMBRE WX WXG 21

    Inscrit:
    Jan 22, 2018
    Messages:
    163
    J'aime reçus:
    321
    Salut

    Bonjour visiteur, Merci de vous Inscrire ou de vous connectez pour voir les liens!

    ,

    Je crois qu'il y a une erreur sur la requête suivante, il manque un Null avant le fournisseur :
    Code (Text):
    SI COMBO_Fourniosseur<>"Tout" ET COMBO_ModeRéglement<>"Tout" ET COMBO_Utilisateurs="Tout" ALORS
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    TableAffiche(TABLE_Réception,taInit)
    HLibèreRequête(REQ_Réception)
    FIN
    Avec le Null :
    Code (Text):
    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,Null,COMBO_Fourniosseur,COMBO_ModeRéglement,Null,Null,Null)
    Le plus simple aurait été d'utiliser une seule requête, c'est plus lisible, par exemple :
    Code (Text):
    sUtil = COMBO_Utilisateurs..ValeurAffichée
    sFourniss = COMBO_Fourniosseur
    sModeRegl = COMBO_ModeRéglement

    SI sUtil = "Tout" ALORS sUtil = Null
    SI sModeRegl = "Tout" ALORS sModeRegl = Null
    SI sModeRegl = "Tout" ALORS sModeRegl = Null

    HExécuteRequête(REQ_Réception,hRequêteDéfaut,Null,SAI_Au,SAI_Du,sUtil,sFourniss,sModeRegl,Null,Null,Null)
    A+.
     
  • Partager cette page

    Chargement...